首页 > 电脑百科 > wordpress更新提示ftp的问题

wordpress更新提示ftp的问题

2015年12月9日 发表评论 阅读评论

最近又新剁手了一个小内存vps,选用debian 6系统,昨天还是用 《快速为小内存vps配置php生产环境教程》 ?中所提到的?lowendbox 配置包做了 LNMP 环境,并下载了 wordpress 程序来做网站程序,调试时又出现了 ?更新wordpress主题、插件提示需要输入ftp信息的问题。

是的,又是可恶的?读写权限 777 , 刚好这个vps的ssh很难链接(便宜没好货!),不然就能用 winscp 直接把整个网站目录、下级目录和文件的权限全部改成777 。只能去后台提交命令了,

? chmod -R 777 /var/www/wordpress

执行后没有反馈错误,但是回到 wordpress 发现问题依旧。查阅之后发现除了文件夹 777 问题之外还可能是用户组问题,前台页面的执行用户并没办法用到777权限,所以有又了下面一条命令。

sudo ?chown -R www-data /var/www/wordpress

上面仅是参考,注意把 ?/var/www/wordpress 自己的网站目录,??lowendbox?配置包的网站目录默认都在 /var/www 下面。

分类: 电脑百科 标签:
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.